雇用契約機能を使って書類を作成中に、「書類の作成に失敗しました。必須項目の内容を確認してください。」と表示されて従業員の書類を作成できない場合は、不足している従業員情報を登録する、もしくは必須項目のチェックを外すことで対処できます。
原因
このエラーメッセージは、書類上で必須と設定されている項目が、従業員情報として未登録になっている場合に表示されます。
書類上で必須と設定されている項目とは、使用した書類テンプレートに設定してある [必須項目] のことです。
設定場所については、本ページの「対処法(必須項目を編集する場合)」にてご案内しています。対処法(不足情報を登録する場合)
1. 不足している従業員情報を登録
従業員情報の画面へ移動して、雇用契約機能で使用する書類上で必須と設定されている従業員情報を登録してください。
従業員情報の更新の手順について詳しくは、下記ページをご覧ください。
[氏名] のリンクをクリックすると、当該の従業員情報画面へ移動できます。
2. [データを再取得する] をクリック
雇用契約機能の画面へ戻り、エラーメッセージが表示されたパネルの右側にある […] メニュー を開いて [データを再取得する] をクリックすると、確認のモーダルが表示されます。
モーダルに表示された [OK] をクリックすると、画面が切り替わり、書類が作成されたことを確認できます。
対処法(必須項目を編集する場合)
1. 書類テンプレートの編集画面にて必須項目のチェックを外す
書類作成に使用している書類テンプレート画面へ移動して、[…] メニュー から [この書類テンプレートを編集する] をクリックすると、テンプレートの編集画面へ移動します。
エラーメッセージが表示された画面上の [この依頼グループでは以下の書類を依頼します。] の下にあるリンクをクリックすると、各書類テンプレート画面へ移動できます。
テンプレート編集画面を下へスクロールすると、[必須項目] を確認できます。
必須項目から外したい項目のチェックを外し、[更新] をクリックしてください。
2. [データを再取得する] をクリック
エラーメッセージが表示された画面へ戻り、パネルの右側にある […] メニュー を開いて [データを再取得する] をクリックすると、確認のモーダルが表示されます。
モーダルに表示された [OK] をクリックすると、画面が切り替わり、書類が作成されたことを確認できます。